Menus

File Menu

New window ( Ctrl+N )

Opens a new main window, with the initial path set to the current folder.

New collection ( C )

Opens a new collection window, the new collection will be empty.

Open collection ( O )

Displays a dialog to open a collection stored on disk, the selected collection will then appear in a new window.

Open recent

This menu item lists the recently active collections, selecting an item from the list will open that collection in a new window. The most recent item will appear at the top of the list. Maximum number of entries can be modified through Open recent list maximum size option.

Search… ( F3 )

Opens a new Search window.

Find duplicates... ( D )

Opens a new Find Duplicates window.

Print.. ( Shift+P )

Opens a print dialog.

New folder… ( Ctrl+F )

Creates a new folder in the current path.

Copy… ( Ctrl+C )

Opens a dialog to select a destination to copy the currently selected files.

Move… ( Ctrl+M )

Opens a dialog to select a destination to move currently selected files.

Rename… ( Ctrl+R )

Renames the current file selection.

Delete… ( Ctrl+D )

Deletes the current file selection.

Symlink

Creates a symbolic link. This is implemented via a plugin .

Close window ( Ctrl+W )

Closes the window containing the menu, if the window is the last main window Geeqie will quit.

Quit ( Ctrl+Q )

Quits the Geeqie application, if collections or image metadata have been changed but not saved, the user will be prompted for confirmation.

Go menu

The Page commands are for files which contain multiple images e.g. .tiff files

First Image ( Home )

Goes to the first image.

Previous Image ( Backspace )

Goes to the previous image.

Next Image ( Space )

Goes to the next image

Last Image ( End )

Goes to the last image

Image Back

Each image you view is appended to a chain. You may traverse forwards and backwards through this chain using this and the following key. Move to the previous image in the chain.

Image Forward

Move to the next image in the chain.

Back

Back Goes to the previous folder

Home ( Home )

Goes to the the Home folder as defined in Window Layout

First Page ( Ctrl+Home )

Goes to the first page.

Last Page ( Ctrl+End )

Goes to the last page.

Previous Page ( Ctrl+PageUp )

Goes to the previous page.

Next Page ( Ctrl+PageDown )

Goes to the next page.

Select menu

Select all ( Ctrl+A )

Selects all files in the current list

Select none ( Ctrl+Shift+A )

Deselects all files

Invert selection ( Ctrl+Shift+I )

Inverts current selection

Rectangular selection ( Alt+R )

Toggles rectangular selection mode for icons

Copy path

Copy selected item-path(s) to clipboard 3 . Each data item copied will be enclosed in quotes.

Copy path unquoted

Copy selected item-path(s) to clipboard. The data will not be enclosed in quotes.

Show marks ( M )

Displays marks in the file list

Clear marks

Clear all marks for all images

Marks that are linked to keywords will also be cleared. This may result in a metadata write operation being triggered.

Mark n

Opens submenu for manipulating mark n

Mark n ▸ Toggle Mark n ( n )

Set or unset mark n on selected files

Mark n ▸ Set mark n

Set mark n on selected files

Mark n ▸ Reset mark n

Unset mark n on selected files

Mark n ▸ Select mark n ( Ctrl+n )

Selects all files having mark n set

Mark n ▸ Add mark n

Adds files having mark n set to selection

Mark n ▸ Intersection with mark n

Intersects current selection and mark n

Mark n ▸ Unselect mark n

Removes files having mark n set from current selection

Mark n ▸ Filter mark n

Shows only the images that have mark n set.

Edit menu

Orientation

Adjust image orientation

Orientation ▸ Rotate clockwise ( ] )

Rotates the current image clockwise 90 degrees, does not modify the file on disk.

Orientation ▸ Rotate counterclockwise ( [ )

Rotates the current image counterclockwise 90 degrees, does not modify the file on disk.

Orientation ▸ Rotate 180 ( Shift+R )

Rotates the current image 180 degrees, does not modify the file on disk.

Orientation ▸ Mirror ( Shift+M )

Swaps the left and right sides of the image so that the result is similar to that of looking at the image in a mirror, does not modify the file on disk.

Orientation ▸ Flip ( Shift+F )

Swaps the top and bottom sides of the image, does not modify the file on disk.

The above orientation commands - Rotate, Mirror and Flip - do not change the image on disk. The changes will be lost when Geeqie closes. Refer to the Metadata tab of the Preferences Dialog if you wish these changes to be written to metadata.

Refer also to the FAQ .

Orientation ▸ Original state ( Shift+O )

Removes all temporary effects applied through the above commands, reverting the image according to its Exif Orientation tag.

Auto rotate image using EXIF information

Auto rotates images based on metadata stored in images that have Exif data. Refer also to the FAQ .

Orientation ▸ Apply the orientation to image content

This command affects only jpeg, tiff and png files. The image file on disk is rotated to the orientation as specified by its Exif Orientation tag.

The file rotate.desktop, using external commands exiftran, exiv2 and mogrify, is used to implement this command. Refer to Plugins section for details.

Orientation ▸ Rotate counterclockwise ( [ )

Rotates the current image counterclockwise 90 degrees, does not modify the file on disk.

Orientation ▸ Rotate 180 ( Shift+R )

Rotates the current image 180 degrees, does not modify the file on disk.

Orientation ▸ Write orientation to file

Saves the current image orientation to the disk file. This operation can only be carried out on jpeg, tiff and png files. Jpeg rotations are lossless.

The Preferences/Metadata option "Write altered image orientation to the metadata" must be off.

Exiftran and mogrify must be installed.

Orientation ▸ Write orientation to file (preserve timestamp)

As above, but the file date and time are preserved.

Rating

Set a Rating value for each image.

Rating ▸ n ( Alt+Keypad+n )

"n" is in the range 0 to 5. Sets the Rating value for the image.

Rating ▸ -1 ( Alt+Keypad+Minus )

Sets the Rating value to -1 for the image.

Save metadata ( Ctrl+S )

Saves queued metadata changes. Autosave can be configured too.

Preferences ( Ctrl+O )

Opens the Preferences Dialog for changing of global preferences.

Configure Plugins…

Opens the Plugins Dialog for changing of desktop files.

Configure This window…

Opens the Window Preferences Dialog for changing of options that can differ for each window.

Cache maintenance

Opens a dialog with utilities for thumbnail and keyword Cache and Data Maintenance .

Set as wallpaper

Renders the current image to the root window (desktop). The resulting image will be tiled to fit the root window if zoom is not set to Fit to window ; when zoom is set to Fit to window , the image will be scaled to fill the root window.

Plugins menu

Plugins

This menu contains the plugins (desktop files) that were found on the system. See the Plugins section for details.

View menu

View in new window ( Ctrl+V )

Opens selected image in its own window

Pan view ( Ctrl+J )

Opens current folder in Pan view window

Exif data ( Ctrl+E )

Toggles display of the Exif sidebar.

Files and Folders ▸ Folder List ( Meta+L )

Set the folder view mode to list.

Files and Folders ▸ Folder Tree ( Ctrl+T )

Set the folder view mode to tree.

Files and Folders ▸ Image List ( Ctrl+L )

Changes the file list to display files in list format.

Files and Folders ▸ Icons ( Ctrl+I )

Changes the file list to display files as icons.

Files and Folders ▸ Show Thumbnails

Toggles the display of image thumbnails in the file list, this item is not available when the file list is in icon view mode. A check appears next to this item when thumbnails are enabled.

Files and Folders ▸ Float file list ( L )

Splits the 3-pane main window into two parts:

  • File pane and Folder pane, along with menu and status bar
  • Image pane and its associated sidebar and sort manager (if displayed)

Files and Folders ▸ Hide file list ( Ctrl+H )

Hides the File and Folder panes, along with menu and status bar. Right-click on the Image pane provides a menu item to redisplay these items.

Files and Folders ▸ Hide toolbar

Toggles visibility of the tool bar. A check appears next to this item when the tool bar is not visible.

Zoom

Zoom ▸ Connected zoom

Actions in this menu are identical to those in Zoom menu, but apply to all images displayed in split view.

Zoom ▸ Zoom in

Increases the zoom by one increment, resulting in a larger image.

Zoom ▸ Zoom out

Decreases the zoom by one increment, resulting in a smaller image.

Zoom ▸ Zoom to fit

Automatically adjusts the zoom so that the image will fit within the display pane. The effect on images with an original size smaller than the display pane can be changed with the Allow enlargement of image for zoom to fit option located on the Image tab of the preferences dialog.

Zoom ▸ Fit Horizontally

Adjusts the zoom so image height fit within the display pane.

Zoom ▸ Fit Vertically

Adjusts the zoom so image width fit within the display pane.

New  ▸ Zoom ▸ Zoom n:m ( Z )

Set zoom to the n:m value. 1:1 is the original size of the image. When n is greater than m, zoom in occurs else zoom out occurs.

Zoom ▸ Zoom n:m ( Z ) Split

Split ▸ Horizontal

Splits main image view in two horizontal panes.

Split ▸ Vertical ( U )

Splits main image view in two vertical panes.

Split ▸ Quad

Splits main image view in four panes.

Split ▸ Single ( Y )

Reverts to normal view mode (one image).

Image Overlay ▸ Image Overlay

Displays Image Overlay information box (OSD), use twice to add histogram to it.

Image Overlay ▸ Histogram channels

Switches channels displayed in the histogram (red, green, blue, RGB, value, maximum value).

Image Overlay ▸ Histogram log mode

Toggles between linear and logarithmical histogram.

Full screen

Toggles the full screen window display.

Over/Under Exposure ( Shift+E )

Toggles highlighting of pixels that are either over or under exposed. This function operates on the displayed pixels. If a raw file is being displayed, the embedded jpeg data is being used. If the image is zoomed, the zoom type affects the results. Two-pass rendering also has some influence.

If a pixel has any channel at zero or full-scale, the pixel is displayed in red.

Keywords

Toggles display of the Keywords sidebar.

Sort manager

Toggles display of the Sort Manager sidebar.

Hide Bars

This item is intended to be used by its shortcut key - by default this is the backtick key. When pressed, the info sidebar, sort manager and file list will be hidden (if displayed). Pressing backtick again will revert the display to its previous layout.

Toggle slideshow

Begins or ends a slide show, the slide show status is displayed in the status bar.

Pause slideshow

Pauses a slide show, the slide show status is displayed in the status bar.

Faster

Decreases slide show interval in units of 0.5 seconds.

Slower

Increases slide show interval in units of 0.5 seconds.

Refresh

Updates the contents of the folder and file lists to match what is currently on disk, the current image will also be reread from disk.

Windows menu

This menu permits you to define several different window layouts that can be recalled at any time.

New window ▸ default ( Ctrl+N )

Opens a new window with the default layout. The window is given a name in the form "lw<n>".

New window ▸ from current

Opens a new window with the layout of the window that has focus. The window is given a name in the form "lw<n>".

Rename window

If a window is given a name that does not begin with the characters "lw", the layout will be saved and be available for loading at a later time..

Delete window

Delete a saved window layout from the list.

Close window

Close the window. If the window is the "main" window, close all windows.

Help menu

Contents ( F1 )

Opens the Geeqie user manual in a new browser window.

Search and Run Commands ( / )

Opens a text box in which you may type characters to find a command. The characters you type will be matched to the first characters of any word in all the commands in Geeqie - both built-in commands and plugins - and matching actions will be displayed in a pop-up. You may scroll to any of the matching commands and press Enter to execute the command. Pressing Enter without selecting from the list will execute the first action in the list. Press Esc to close the box.

On-line help search

Use a web browser to search Geeqie's on-line help files. The search engine used is defined in Preferences General .

Keyboard shortcuts

Displays a window listing the default keyboard shortcuts.

Keyboard Map

Displays an image showing the currently allocated keyboard shortcuts.

Release notes

Displays a window containing the release notes for the version of Geeqie in use.

About

Opens a window containing the Geeqie version, credits, website, and email contact information.

Log window

Opens the log window, mostly used for debugging purposes.

Tear off menus

Menus can be permanently displayed by selecting the dotted line item at the top of each menu category. A tear off menu will behave the same as an ordinary window. To close a tear off menu, select the dotted line item at the top of the menu.

Keyboard shortcuts

The keyboard sequence associated to each menu entry is listed within the main window menu bar. For reference, the complete list of default keyboard shortcuts can be found in section Keyboard Shortcuts .

Changing the main window menu bar keyboard shortcuts

The section Keyboard Options describes how to modify the keyboard shortcuts used in the main menu.

3 The clipboard used is selected here.